The W8 forum Homepage
Forum Home Forum Home > Problems, Tips and Tricks About the W8 > Electronics
  New Posts New Posts RSS Feed: Losing power
  FAQ FAQ  Forum Search   Register Register  Login Login

 Shoutbox  Your message
You must log in to shout!

Losing power

 Post Reply Post Reply
Author
Message
kdm_42089 View Drop Down
Newbie
Newbie


Joined: 30-Apr-2013
Location: Shelbyville, Il
Online Status: Offline
Posts: 4
  Quote kdm_42089 Quote  Post ReplyReply Direct Link To This Post Topic: Losing power
    Posted: 15-May-2013 at 15:57
When driving down the road, all of my gauges and lights will go to zero/turn off then come right back on. I have also been having issues with my door locks and windows not working from the drivers door either. And the cruise only works for maybe, two seconds then shuts off. Any advice?
Back to Top
RobG View Drop Down
Senior Member
Senior Member


Joined: 01-Dec-2008
Location: UK
Online Status: Offline
Posts: 397
  Quote RobG Quote  Post ReplyReply Direct Link To This Post Posted: 15-May-2013 at 19:47
Check your battery connections are good, had something similar (only when starting) on a previous car turns out i had enough crap around the battery terminals as it was breaking the connection.
Door locks and windows could be the CCM unit, have a check under the passenger side carpet see if it's wet (there's a whole section devoted to this in one of the forums)
Cruise control could be either your brake or clutch switch being faulty. I had an issue where my cruise would work fine for a bit, then it would just cut out, it was (in my case) a faulty brake switch.
Hope this gives you a starting point :)
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down

Bulletin Board Software by Web Wiz Forums® version 9.56a
Copyright ©2001-2009 Web Wiz

This page was generated in 0,063 seconds.