The W8 forum Homepage
Forum Home Forum Home > Problems, Tips and Tricks About the W8 > Electronics
  New Posts New Posts RSS Feed: Malfunction Indicator Lamp
  FAQ FAQ  Forum Search   Register Register  Login Login

 Shoutbox  Your message
You must log in to shout!

Malfunction Indicator Lamp

 Post Reply Post Reply Page  12>
Author
Message
mike View Drop Down
Newbie
Newbie
Avatar

Joined: 13-Nov-2007
Location: United States
Online Status: Offline
Posts: 34
  Quote mike Quote  Post ReplyReply Direct Link To This Post Topic: Malfunction Indicator Lamp
    Posted: 18-May-2008 at 14:27
My Malfunction Indicator Lamp lit up the other day and I am not really sure what to do. I have also noticed recently that my radiator fan is remaining on a lot longer than previous after I turn the ignition off. I am going to have a buddy send down his Vag-Com, but until then is there anything that I should look at?
'03 W8 4 Motion
Back to Top
squish View Drop Down
Super Poster
Super Poster
Avatar

Joined: 09-Dec-2006
Location: Atlanta
Online Status: Offline
Posts: 535
  Quote squish Quote  Post ReplyReply Direct Link To This Post Posted: 18-May-2008 at 22:46
autozone scans for free and gives the analysis too. pray it isn't the thermostat!
2005 V70 R
2007 2.0T 6MT
Back to Top
mike View Drop Down
Newbie
Newbie
Avatar

Joined: 13-Nov-2007
Location: United States
Online Status: Offline
Posts: 34
  Quote mike Quote  Post ReplyReply Direct Link To This Post Posted: 19-May-2008 at 09:30
wow I am scared now, why do I not want it to be the thermostat??
'03 W8 4 Motion
Back to Top
Corwin View Drop Down
Senior Member
Senior Member


Joined: 07-Jun-2007
Online Status: Offline
Posts: 191
  Quote Corwin Quote  Post ReplyReply Direct Link To This Post Posted: 19-May-2008 at 11:29
Assuming it requires near-removal of entire engine...
Back to Top
cantw8 View Drop Down
Groupie
Groupie


Joined: 28-Mar-2008
Location: Seattle, WA
Online Status: Offline
Posts: 80
  Quote cantw8 Quote  Post ReplyReply Direct Link To This Post Posted: 19-May-2008 at 12:32
Originally posted by mike

My Malfunction Indicator Lamp lit up the other day and I am not really sure what to do. I have also noticed recently that my radiator fan is remaining on a lot longer than previous after I turn the ignition off. I am going to have a buddy send down his Vag-Com, but until then is there anything that I should look at?


How many miles do you have?

My MIL turned on at 44,000 miles and had the same symptoms.    It ended up being the coolant temp sensor.

Took my car to the dealer and they had it fixed and back to me the same day.    The total bill was under $200.00, but my (extended) warranty took care of it.

Edited by cantw8 - 19-May-2008 at 18:36
2003 W8 Variant, 6MT, Blue Spirit Pearl / Gray

Back to Top
mike View Drop Down
Newbie
Newbie
Avatar

Joined: 13-Nov-2007
Location: United States
Online Status: Offline
Posts: 34
  Quote mike Quote  Post ReplyReply Direct Link To This Post Posted: 20-May-2008 at 11:57
Right now I have 39,000 miles on it.

I noticed the other day that I was low on coolant so I topped it off, hoping that would be the problem, it wasn't. :(

I am going to take it to get scanned today and hopefully it is something cheap and quick to fix, if that exist on the W8.
'03 W8 4 Motion
Back to Top
mike View Drop Down
Newbie
Newbie
Avatar

Joined: 13-Nov-2007
Location: United States
Online Status: Offline
Posts: 34
  Quote mike Quote  Post ReplyReply Direct Link To This Post Posted: 21-May-2008 at 17:18
Had it scanned for free at Auto Zone and it is giving the following code:

P0599
Cruise Control
Control Circuit High

That does not make any sense to me.
'03 W8 4 Motion
Back to Top
BlueSteW8 View Drop Down
Super Poster
Super Poster


Joined: 08-Dec-2006
Location: SW-FL, US
Online Status: Offline
Posts: 906
  Quote BlueSteW8 Quote  Post ReplyReply Direct Link To This Post Posted: 22-May-2008 at 18:51
If you were low on coolant, it went somewhere - do you smell it?
2003 W8 Tip Limousine - locked in sports mode
GIAC pump/stock/ race files
Blue Spirit/ Black
Back to Top
VWAffe View Drop Down
Super Poster
Super Poster
Avatar

Joined: 26-Mar-2007
Location: Dayton, OH
Online Status: Offline
Posts: 494
  Quote VWAffe Quote  Post ReplyReply Direct Link To This Post Posted: 22-May-2008 at 23:53
Not sure if that is a valid code for Cruise Control on another engine version of Passat, but AutoZone got it wrong.

The Bentley manual says that the SAE OBDII Code P0599 on the W8 (BDP) is... you're gonna hate this... Thermostat Heater Control Circuit High.

Diagnosis involves removing the upper and lower intake manifold to get to the thermostat, measuring the resistance of the thermostat heater coil, and checking the wiring between it and the ECU for continuity, shorts, open circuits, and the like.

The problem could be the thermostat, wiring, or the ECU. Or... could maybe also be one of the two temp sensors.

Edited by VWAffe - 23-May-2008 at 06:05
'03 W8 Sedan 6MT     ..."it goes to 11!"
'02 V6 Wagon 4Mo 5MT (Swap In Work)     ...both black on black w/ limo tint
'14 JSW TDI 6MT
Back to Top
SirRangeALot View Drop Down
Moderator
Moderator
Avatar

Joined: 09-Dec-2006
Location: Dubuque, Iowa
Online Status: Offline
Posts: 2373
  Quote SirRangeALot Quote  Post ReplyReply Direct Link To This Post Posted: 23-May-2008 at 02:22
Ouch.
Get a wagon. Bitches love wagons.
Back to Top
 Post Reply Post Reply Page  12>

Forum Jump Forum Permissions View Drop Down

Bulletin Board Software by Web Wiz Forums® version 9.56a
Copyright ©2001-2009 Web Wiz

This page was generated in 0,070 seconds.